pátek 13. března 2015

DRAC 5 a Java 8

Pokud aktualizujete Javu na verzi 8 (testováno na verzi je Java 8u31), můžete si tak odříznout přístup na starší Dell Remote Access Controllery. U mne se to týkalo DRAC 5.

Při spuštění Console nebo Virtual Media vyskočí toto okno a konec:
V Javě 8 z bezpečnostních důvodů byla vypnuta podpora SSLv3, kterou tyto DRAC karty používají.

Jediným řešením je v Javě SSLv3 povolit:

V souboru
C:\Program Files\Java\jre1.8.0_31\lib\security\java.security
naleznete řádek
jdk.tls.disabledAlgorithms=SSLv3
Ten jednoduše zakomentujte vložením # na začátek. Pak už vzdálená konzola půjde spustit.
#jdk.tls.disabledAlgorithms=SSLv3
Pozor: cesta k souboru se liší podle verze Javy a Windows (32bit / 64bit)!

Žádné komentáře:

Okomentovat